No suitable codecs found

I am trying to run GetPileupSummaries, but when running the script I get the error related to no suitable codecs found.

Here is the code:

gatk GetPileupSummaries -I SRR13147304_good.bam -V 1000GENOMES-phase_3.gvf.gz -L 1000GENOMES-phase_3.gvf.gz -O pileups.table
Using GATK jar /home/carlosbarron/Downloads/gatk-
    java -Dsamjdk.use_async_io_read_samtools=false -Dsamjdk.use_async_io_write_samtools=true -Dsamjdk.use_async_io_write_tribble=false -Dsamjdk.compression_level=2 -jar /home/carlosbarron/Downloads/gatk- GetPileupSummaries -I SRR13147304_good.bam -V 1000GENOMES-phase_3.gvf.gz -L 1000GENOMES-phase_3.gvf.gz -O pileups.table
23:06:49.247 INFO  NativeLibraryLoader - Loading from jar:file:/home/carlosbarron/Downloads/gatk-!/com/intel/gkl/native/
23:06:49.731 INFO  GetPileupSummaries - ------------------------------------------------------------
23:06:49.731 INFO  GetPileupSummaries - The Genome Analysis Toolkit (GATK) v4.2.6.1
23:06:49.732 INFO  GetPileupSummaries - For support and documentation go to
23:06:49.732 INFO  GetPileupSummaries - Executing as carlosbarron@carlosbarron-HP-Laptop-15-ef1xxx on Linux v5.15.0-33-generic amd64
23:06:49.732 INFO  GetPileupSummaries - Java runtime: OpenJDK 64-Bit Server VM v1.8.0_312-8u312-b07-0ubuntu1~20.04-b07
23:06:49.732 INFO  GetPileupSummaries - Start Date/Time: June 21, 2022 11:06:49 PM EDT
23:06:49.732 INFO  GetPileupSummaries - ------------------------------------------------------------
23:06:49.732 INFO  GetPileupSummaries - ------------------------------------------------------------
23:06:49.733 INFO  GetPileupSummaries - HTSJDK Version: 2.24.1
23:06:49.733 INFO  GetPileupSummaries - Picard Version: 2.27.1
23:06:49.733 INFO  GetPileupSummaries - Built for Spark Version: 2.4.5
23:06:49.733 INFO  GetPileupSummaries - HTSJDK Defaults.COMPRESSION_LEVEL : 2
23:06:49.734 INFO  GetPileupSummaries - HTSJDK Defaults.USE_ASYNC_IO_READ_FOR_SAMTOOLS : false
23:06:49.734 INFO  GetPileupSummaries - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_SAMTOOLS : true
23:06:49.734 INFO  GetPileupSummaries - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_TRIBBLE : false
23:06:49.734 INFO  GetPileupSummaries - Deflater: IntelDeflater
23:06:49.734 INFO  GetPileupSummaries - Inflater: IntelInflater
23:06:49.734 INFO  GetPileupSummaries - GCS max retries/reopens: 20
23:06:49.734 INFO  GetPileupSummaries - Requester pays: disabled
23:06:49.735 INFO  GetPileupSummaries - Initializing engine
23:06:50.115 INFO  GetPileupSummaries - Shutting down engine
[June 21, 2022 11:06:50 PM EDT] done. Elapsed time: 0.01 minutes.

A USER ERROR has occurred: Cannot read file:///home/carlosbarron/Documents/Sequencias/1000GENOMES-phase_3.gvf.gz because no suitable codecs found


After that, I tried to get an index for the gvf file using gatk IndexFeatureFile, nevertheless, when running the program I got the same error. I also tried to gunzip my gvf.gz file and then gzip again, thinking of a mistake of the compress method, but still, I get the same error when running the code.


Could someone help me, please?


1 comment

  • Comment author
    Josh Evans

    Hi Carlos,

    Thank you for writing in about this issue. Can you share the workspace where you are seeing this issue with Terra Support by clicking the Share button in your workspace? The Share option is in the three-dots menu at the top-right.

    1. Toggle the "Share with support" button to "Yes"
    2. Click Save

    Please provide us with

    1. A link to your workspace
    2. The relevant submission ID
    3. The relevant workflow ID

    We’ll be happy to take a closer look as soon as we can!

    Kind regards,



Please sign in to leave a comment.