Docker image not found

Post author
Oliver Ruebenacker

     Hello,

This had worked before, and all I changed was the version of the Docker image from 1.5.0 to 1.6.0 and it no longer works. I ran

gcloud builds submit --timeout=60m --tag gcr.io/nitrogenase-docker/nitrogenase-metastaar:1.6.0

I got:

DONE
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ID                                    CREATE_TIME                DURATION  SOURCE                                                                                            IMAGES                                                 STATUS
caa81d9a-9123-4735-86ba-5493df17f76d  2022-02-23T16:58:11+00:00  46M17S    gs://nitrogenase-docker_cloudbuild/source/1645634182.100549-f6bbfb938fea46af99d96534f09c3efd.tgz  gcr.io/nitrogenase-docker/nitrogenase-metastaar:1.6.0  SUCCESS

Then, in my WDL task, I had

docker: "gcr.io/nitrogenase-docker/nitrogenase-metastaar:1.6.0"

And the task failed with:

"Task metastaar.calculate_summary_stats:236:1 failed. The job was stopped before the command finished. PAPI error code 9. Execution failed: generic::failed_precondition: pulling image: docker pull: running ["docker" "pull" "gcr.io/nitrogenase-docker/nitrogenase-metastaar:1.6.0"]: exit status 1 (standard error: "Error response from daemon: manifest for gcr.io/nitrogenase-docker/nitrogenase-metastaar:1.6.0 not found: manifest unknown: Failed to fetch \"1.6.0\" from request \"/v2/nitrogenase-docker/nitrogenase-metastaar/manifests/1.6.0\".\n")"

Any idea? Thanks!

Best, Oliver

Comments

0 comments

Please sign in to leave a comment.