Need Help?

Search our documentation and community forum

Terra is a cloud-native platform for biomedical researchers to access data, run analysis tools, and collaborate.
Terra powers important scientific projects like FireCloud, AnVIL, DataSTAGE. Learn more.

Installation path not writeable

Comments

10 comments

  • Avatar
    Sushma Chaluvadi

    Hello Mahdiar,

    Have you been able to test the same steps within the new Bioconductor Default Environment option? If so, is there a particular reason that you are using Default? 

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    I tested the install command with the default Bioconductor environment and it looks to have worked successfully:

    1
    Comment actions Permalink
  • Avatar
    Mahdiar Sadeghi

    Thanks for your reply. Can you please check if you can load the package too? It seems that you got the same error as mine: "Installation path not writable..."

    I am using the default environment to have python and R notebooks in the same workspace, also the package the "reticulate" seems to work only on default environment. 

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    Hello Mahdiar,

    Sorry about that! You are right, I do get the same error. I realized that DESeq 1.24.0 is already installed in the default Bioconductor Runtime Environment which is possibly the reason we are unable to overwrite with a newer version. Have you attempted to run your DESeq2 commands without trying to install again? Additionally, If you need a different version we can reach out to the appropriate teams to update the version.

    1
    Comment actions Permalink
  • Avatar
    Mahdiar Sadeghi

    Thank you Sushma,

    Yes. DESeq2 is already installed. Can you please also check ImulseDE

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    Mahdiar,

    You can check all the installed libraries from the Runtime Environment widget. If you click on the gear icon you should see an option to "See What's Installed in this Environment"

     

     

    Clicking on the option will show you a list and you can toggle between Python and R options:

     

     

    0
    Comment actions Permalink
  • Avatar
    Mahdiar Sadeghi

    Thanks for your guidance. Yes this package is not installed and I am not able to install it. 

    Note that I am using the default environment. 

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    Hello Mahdiar,

    It looks like in the Default Runtime Environment, the R version is 3.5.2. Looks like when you try to install ImpulseDE in the default version, one of the dependencies, amap, is not available for that version of R. However, in the Bioconductor runtime environment, there is a higher version of R, 3.6.1, which allows for ImpulseDE to be installed.
     
    I used the following code to test:
     
    devtools::install_github('YosefLab/ImpulseDE', dependencies = TRUE)
     
    This worked in the Bioconductor runtime environment but not the Default - most likely due to the R version that amap needs.

    If you are familiar, you could create your own Docker Image with all the versions of software that you need and create a Custom Runtime Environment. This would require that you work from a terra base image and add your modifications to the Dockerfile.
    You can try using the Bioconductor or please keep an eye on Release Notes where we would update if we change the version of R in the Default Runtime Environment.
    Sushma
    0
    Comment actions Permalink
  • Avatar
    Mahdiar Sadeghi

    Hi Sushma,

    Thank you so much for looking into this!

    If the problem with Default environment is with the R version, would it be possible to install previous version the ImpulseDE package? 

    I am interested to work on Default environment as I need python capability in the workspace. 

    Mahdiar

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    Hello Mahdiar,

    The problem does not seem to be with the actual ImpulseDE package. Rather, the issue is from a dependency of ImpuseDE, amap, which is what is requiring R version > 3.6.0. Currently the Biconductor environment is the one that supports this. We will roll out a Default environment in the future with an updated version of R but I am not sure on the exact date of when that will be. I can most definitely help test more if something does not work correctly. If you can share some commands one might run with ImpulseDE, I'm happy to check if my install commands work in the manner you would expect!

    However, you mentioned not being able to use Reticulate in the Bioconductor environment so I tested this with the command below and it seems to be able to successfully install the package. Are you having specific issues with using the package?

    install.packages("reticulate", repos="https://cran.rstudio.com")

    Also, can you clarify a bit more what issues you are having with running R and Python Notebooks with the Bioconductor environment? I tested this also and was able to run both codes.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk