Need Help?

Search our documentation and community forum

Terra is a cloud-native platform for biomedical researchers to access data, run analysis tools, and collaborate.
Terra powers important scientific projects like FireCloud, AnVIL, and BioData Catalyst. Learn more.

Bug Report: Relaunching Failures

Comments

8 comments

  • Avatar
    Sushma Chaluvadi

    Thanks for the report Jett,

    We will take a look and get back to you with any updates!

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    Jett,

    We have isolated what is happening. In this example, I have submitted a Workflow named hello-world that outputs a string "test-outputs":

     

    and the Job History tab shows this submission as successful. Note the name of the submission wdl-testing/hello-world:

    Then, I go back to the Workflow and make changes in it that require me to press "Save" - thus modifying the Workflow. When I run the Workflow again and check the Job History you can see that the first submission's name has changed with some random text appended at the end. 

    If it had not finished successfully with the "Done" and instead had failed and given me the option to "Relaunch Failures", I would press the button and get the same error that you received. This is because the Workflow was modified since I submitted the first Workflow with different configurations. 

    You should be able to go back and manually set up the Workflow to re-run the first failed run as a workaround. We have a ticket generated to look into this behavior and hope to get back to you with an update soon.

     

    0
    Comment actions Permalink
  • Avatar
    Liudmila Elagina

    Hello Sushma,

    This error is not because configurations were changed. I reported this error before (https://support.terra.bio/hc/en-us/community/posts/360043380192-Error-invalid-input-while-launching-workflow). I still encounter it without changing configurations. It seems on the forum it was suggested that workflow's names should not have dots (.). However, this pipeline launches without any problem through the Tool tab in the workspace but fails when trying to re-launch failures.

    Can you test it with the workflow that has dot in it's name?

    Thank you,

    Luda

    0
    Comment actions Permalink
  • Avatar
    Sushma Chaluvadi

    Hi Luda,

    Will definitely test it with the same workflow that you reported but I wanted to clarify that "changing configuration" means modifying anything that requires the button press on "Save". Can you confirm that between launching analysis, analysis failing, and pressing Relaunch, the Workflow was not at all modified in any way?

    I would like to add all pertinent details to the bug report.

    0
    Comment actions Permalink
  • Avatar
    Liudmila Elagina

    Yes, I confirm that I didn't modify configurations between launches.

    0
    Comment actions Permalink
  • Avatar
    Adam Nichols

    Hi folks,

    It looks like we've inadvertently created a situation where part of the application is accepting periods in method names, while another part rejects them. We apologize for this inconsistent and confusing behavior!

    We are looking into exactly what's going on; in the meantime your best bet is to try again with no periods.

    Regards,

    Adam

    (Terra developer)

    0
    Comment actions Permalink
  • Avatar
    Adam Nichols

    Hi Jett,

    We identified and fixed a bug that caused the "relaunch failures" feature to fail unexpectedly with the "Error 400: Invalid input" message when the workflow's method name contained the period character. Regular (initial) submissions were not affected.

    The fix should be in production next week, most likely Monday 12/16.

    We are still looking into your second error where the application emits a 404 status code.

    Best,

    Adam

    0
    Comment actions Permalink
  • Avatar
    Adam Nichols

    Hi Jett,

    I have an update on the second error.

    Method configurations obey the following semantics:

    When an edit is made, we create a new method config version and archive the old one

    The archived configs are marked by appending a 10-character hash like

    vanallenlab/CGA_WES_Characterization_Pipeline_v0.1_Dec2018_VA_cwjwUlnHX4g

    Archived configs cannot be launched, so we should not be displaying the "Relaunch Workflows" button for them. This inconsistency will be addressed in next week's release.

    While working the problem it became obvious that launching previous versions of method configs could actually be really useful, so I filed a ticket to investigate that possibility.

    Cheers,

    Adam

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk