refused to connect.

Post author
SanjaY K

Hi Everyone, I'm a new user to Terra. I was trying to follow along the quickstart tutorials, specifically the T101-Notebooks-Quickstart copy. When I start up the workspace and go to the analyses page, I created a Jupyter notebook environment. It seems to have created it successfully but when I click on 'open' to try and edit/run it, I get an error for refused to connect. It looks like the environment is running fine according to terra but I get a connection refusal and can't really do anything. Has anyone else experienced this error?



  • Comment author
    Edyta Malolepsza

    Hi Terra team!

    I have the same problem as reported by Sanja: jupiter notebooks that worked fine last week do not open today:

    I will appreciate your help.

    Best regards,

    Edyta Malolepsza

  • Comment author
    Hoyin Chu

    Hi Terra team,

    I am also experiencing the same issue as the previous two users in my own Terra workspace where the same error pops up after trying to connect to my notebooks. I have tried switching to different preset environments as well as different notebooks but to no avail, This has never happened before and any clues to why or workarounds would be greatly appreciated.

    Thank you!


  • Comment author
    Anthony DiCi

    Hi SanjaY, Edyta, and Hoyin,
    Thanks for writing in with this issue! A member of the Terra support team will follow up with you as soon as they are able.
    If relevant, please let us know if there is any urgency around this request so that the team can prioritize it appropriately.
    Kind regards,

  • Comment author
    Josh Evans

    Hi All,

    Sorry for the delayed response.  There may actually be two different issues happening here. SanjaY and Edyta, when you were having this issue there was a Service Incident that was affected the Cloud Environments and we have seen it cause the issues you're reporting above.  Please try to connect to your notebooks and if you have the errors again, please provide the information below.

    Hoyin, because the Service Incident was resolved there could be a different reason for the error you're seeing. The first thing I would check is the age of the Cloud Environment.  You can find that on this page under the created column.  If it's older than a month, I would delete it and create a new one.  After a certain time, Cloud Environments need to be deleted because errors like this can happen.  Note: please do not delete the Persistent Disk to avoid data loss.

    If that doesn't resolve the issue, then please provide the follow information and we'll take a look as soon as we can:

    • Terra account email address
    • Google Project ID for workspace, found on the right side of the workspace dashboard
    • Cluster ID (visit, click Details, and see Name field)
    • Screenshot of your cloud environment configuration
    • Approximate time issue first occurred

    Please let me know if you have any questions.




Please sign in to leave a comment.