Paired-Fastq-to-Unmapped-Bam stopped with the message "No space left on device".

Post author

Hi, @Samantha. I'm new to Terra and need your help for my revise experiments!!

I tried Paired-Fastq-to-Unmapped-Bam with my own files but it stopped. I think it may be because "No space left on device". Part of the Stderr file is shown below. Could you help me??

I am not sure how Terra works, but where do I set the disk space that I can use? When I created a Jupyter Notebook VM in the Tutorial, I set a persistent disk space. However, when I just run Workflow, I can run it without setting the disk space.

- workspace:
- Submission ID: <cc96492c-43ce-47aa-bcf3-4431cba5d71e>
- workflow ID: eb0279a4-5813-4241-a042-0e6a63677b06
- workflow ID: 0bb3de91-9dd2-4244-83d6-e3f53060b87f
- workflow ID: 1c077068-4951-4ad1-b805-21ed2cb58628
- workflow ID: 8d19c686-a552-4c83-8208-f4663cb27645
- I heve toggled the "Share with support" button to "Yes".

INFO    2023-01-24 07:15:34    FastqToSam    Processed 1,050,000,000 records.  Elapsed time: 03:09:30s.  Time for last 1,000,000:    9s.  Last read position: */*
INFO    2023-01-24 07:15:44    FastqToSam    Processed 1,051,000,000 records.  Elapsed time: 03:09:40s.  Time for last 1,000,000:    9s.  Last read position: */*
INFO    2023-01-24 07:15:51    FastqToSam    Processed 525759724 fastq reads
[Tue Jan 24 08:11:34 GMT 2023] picard.sam.FastqToSam done. Elapsed time: 245.54 minutes.
To get help, see
htsjdk.samtools.util.RuntimeIOException: Write error; BinaryCodec in writemode; streamed file (filename not available)
    at htsjdk.samtools.util.BinaryCodec.writeBytes(
    at htsjdk.samtools.util.BlockCompressedOutputStream.writeGzipBlock(
    at htsjdk.samtools.util.BlockCompressedOutputStream.deflateBlock(
    at htsjdk.samtools.util.BlockCompressedOutputStream.write(
    at htsjdk.samtools.util.BinaryCodec.writeBytes(
    at htsjdk.samtools.util.BinaryCodec.writeBytes(
    at htsjdk.samtools.BAMRecordCodec.encode(
    at htsjdk.samtools.BAMFileWriter.writeAlignment(
    at htsjdk.samtools.SAMFileWriterImpl.close(
    at htsjdk.samtools.AsyncSAMFileWriter.synchronouslyClose(
    at htsjdk.samtools.util.AbstractAsyncWriter.close(
    at picard.sam.FastqToSam.doWork(
    at picard.cmdline.CommandLineProgram.instanceMain(
    at org.broadinstitute.hellbender.cmdline.PicardCommandLineProgramExecutor.instanceMain(
    at org.broadinstitute.hellbender.Main.runCommandLineProgram(
    at org.broadinstitute.hellbender.Main.mainEntry(
    at org.broadinstitute.hellbender.Main.main(
Caused by: No space left on device
    at Method)
    at java.nio.channels.Channels.writeFullyImpl(
    at java.nio.channels.Channels.writeFully(
    at java.nio.channels.Channels.access$000(
    at java.nio.channels.Channels$1.write(
    at htsjdk.samtools.util.BinaryCodec.writeBytes(
    ... 16 more



  • Comment author
    Samantha (she/her)

    Hi KM,

    Thanks for reaching out. You are correct that the reason the workflow is failing is because of insufficient disk space. You'll need increase the disk space and resubmit the workflow.

    When running a workflow on Terra, the VM settings are configured in the WDL script, in the `runtime` section of the task. There are default runtime attribute values used if no value is specified.

    Here is the runtime section for the PairedFastQsToUnmappedBAM task.

    Disk space is calculated a few lines above 

    In the Inputs tab of the workflow configuration, you have the option to override the default values of machine_mem_gb and additional_disk_space_gb. 


    I hope this helps. Please let me know if you any other questions.




  • Comment author

    Hi Samantha, thank you for your kindness. It worked well and I really appreciate your help.


Please sign in to leave a comment.